Save a model as older version

Hi,

Is it possible to save a model as older version? I have 5.3 and I would like to save model for previous vesion, e.g. 5.2.


4 Replies Last Post 2018年1月16日 GMT-0500上午5:16
Posted: 2 weeks ago 2018年1月12日 GMT-0500下午7:20

As far as I know it is not possible to do so.

-------------------
Pu, ZHANG
Huazhong University of Science and Technology
As far as I know it is not possible to do so.

Henrik Sönnerlind COMSOL Employee
Posted: 1 week ago 2018年1月15日 GMT-0500上午8:00
Updated: 1 week ago 2018年1月16日 GMT-0500上午5:11

Hi,

For obvious reasons, this cannot be done if you have used functionality which was not available, or has been significanly changed since version 5.2. In many cases, it is however possible:

Save the model as a Java file, compile it, and run the generated class file from the older version. This will work as long as there is nothing in that Java file which is not supported. A few such things can also be fixed by editing the Java file. So it may be worth trying.

Regards,

Henrik

Hi, For obvious reasons, this cannot be done if you have used functionality which was not available, or has been significanly changed since version 5.2. In many cases, it is however possible: Save the model as a Java file, compile it, and run the generated class file from the older version. This will work as long as there is nothing in that Java file which is not supported. A few such things can also be fixed by editing the Java file. So it may be worth trying. Regards, Henrik

Posted: 1 week ago 2018年1月16日 GMT-0500上午4:06

Hi,

If I want to send my simulation to someone who have version 5.2, what do I need to send? This .class and .mph, or just .class, or something else?

Thanks, Milana

Hi, If I want to send my simulation to someone who have version 5.2, what do I need to send? This .class and .mph, or just .class, or something else? Thanks, Milana

Henrik Sönnerlind COMSOL Employee
Posted: 1 week ago 2018年1月16日 GMT-0500上午5:16
Updated: 1 week ago 2018年1月16日 GMT-0500上午5:38

Hi Milana,

If we assume that you do not have 5.2, and your collegue has that version, the best would be that you sava as Java (preferably after having done a Compact History). You then send the Java file, so that the other user has a possibilty to edit it, if necessary.

Regards,

Henrik

Hi Milana, If we assume that you do not have 5.2, and your collegue has that version, the best would be that you sava as Java (preferably after having done a Compact History). You then send the Java file, so that the other user has a possibilty to edit it, if necessary. Regards, Henrik

Reply

Please read the discussion forum rules before posting.

Please log in to post a reply.

Note that while COMSOL employees may participate in the discussion forum, COMSOL® software users who are on-subscription should submit their questions via the Support Center for a more comprehensive response from the Technical Support team.