系统要求 - COMSOL Multiphysics® 5.2a 版本

以下要求适用于所有平台:

  • 安装过程中建议网卡正常工作并连上互联网。
  • 至少应有 1 GB 内存,建议每个处理器内核配置 4 GB 或更多。
  • 1 - 5 GB 的磁盘空间,具体取决于许可产品及安装选项。
  • Adobe® Acrobat® Reader 10.1.9、11.0.06 或更新版本,以便查看和打印 PDF 格式的 COMSOL® 文档。

有关硬件的更多推荐信息,请参见我们的知识库入口

浮动网络许可证

Windows®、Linux® 以及 Mac OS X 计算机组成的异构网络中支持浮动网络许可证类型。许可证管理器和 COMSOL® 软件都可以运行在 Windows®、Linux® 或 Mac OS X 上,二者也可以在同一台计算机上运行。 在高性能计算 (HPC) 中建议使用本许可证类型,获得最佳性能表现,在包含混合建模的分布式内存并行中,也需要使用本许可证类型。

课堂许可证套装 (CKL)

课堂许可证套装的系统要求与浮动网络许可证类似。

App 开发器

App 开发器支持 Windows® 操作系统。

操作系统要求

除下面所列的操作系统要求之外,请参见接口产品套件要求,查看 CAD 导入模块、设计模块和 LiveLink™ 产品套件的具体要求。

Windows® macOS Linux®
64 位操作系统
  • Windows® 10
  • Windows® 8.1
  • Windows® 8
  • Windows® 7
  • Windows Server® 2016
  • Windows Server® 2012 R2
  • Windows Server® 2012
  • Windows Server® 2008 R2
  • Windows Server® 2008
  • Windows HPC Server 2008 R2
  • Windows HPC Server 2008
  • Windows Vista®
Mac OS X 10.7 和 OS X 10.8, 10.9, 10.10, 10.11, 以及 macOS 10.12
  • Debian® 7 和 8
  • Red Hat® Enterprise Linux® 51, 6 和 7
  • Ubuntu® 12.04 LTS, 14.04 LTS 和 Ubuntu® 16.04 LTS
  • OpenSUSE® 13.2 和 OpenSUSE® Leap 42.1

1 仅支持服务器、批处理和集群操作。

具体操作系统要求

Linux®
  • GNU C Library 2.8 或更高版本1
  • Linux® kernel 2.6.18 或更高版本。
  • Intel® Pentium® IV 或 AMD Athlon® XP 处理器或更高版本。
  • FlexNet® 需要 Linux 标准库 (LSB)。

1 如果系统中安装有 libstdc++ 6.0.9 或更早版本,可能需要通过 -forcegcc 选项启动 COMSOL。

帮助系统

当帮助模式设为 Web 浏览器时,暂不支持以下浏览器类型

  • Google Chrome™ 浏览器
  • Microsoft Edge™ 浏览器

Linux® 帮助系统

为了使帮助系统能在 Linux® 中运行,需安装以下软件包:

  • Debian® 及 Ubuntu®: libwebkitgtk-1.0-0
  • RHEL: webkitgtk (未包含在 RHEL7 中,但可通过 EPEL 下载)。
  • openSuSE: libwebkitgtk-1.0-0libwebkit-1_0-2(基于具体版本)。

如未能满足上述要求,COMSOL 软件可能会在您访问帮助系统时崩溃。

图形系统要求

基于性能方面的考虑,COMSOL® 推荐使用硬件渲染。硬件渲染要求驱动器支持 OpenGL® 版本 2.0。Windows® 用户可能还要在本地控制台中使用 DirectX® 版本 9。硬件渲染要求图形颜色至少为 24 色。

“图形”首选项中的“优化质量”设置要求 OpenGL® 2.0。软件渲染也支持 16 位的颜色图形。基于性能方面的考虑,我们建议显卡的内存至少为 512 MB。

AMD®

显卡型号 操作系统 驱动程序版本
AMD FirePro™ V4800 Ubuntu® 14.04 LTS 15.201.2401
AMD FirePro™ V5900 Ubuntu® 12.04 LTS 15.201.2401
AMD FirePro™ V7750 Windows Server® 2008 8.911.3.4000
AMD FirePro™ W2100 Red Hat Enterprise Linux® 7 15.302.2001
AMD FirePro™ W4100 Windows® 10 Enterprise 15.302.2001
AMD FirePro™ W4170M Windows® 7 14.301.1019
AMD FirePro™ W5000 Windows® 10 15.302.2001
AMD FirePro™ W5100 Windows® 8.1 15.302.2001
AMD FirePro™ W7000 Windows Server® 2012 R2 15.302.2001
AMD FirePro™ W7100 Windows® 7 15.201.2401
AMD FirePro™ W8000 Ubuntu® 16.04 LTS AMDGPU
AMD Radeon™ Pro WX4100 Windows® 10 16.50.2001

NVIDIA®

显卡型号 操作系统 驱动程序版本
Quadro® K5000 Windows® 7 362.56
Quadro® K4000 Windows® 7 362.56
Quadro® K2200 Windows® 7 362.56
Quadro® K2000 Windows® 7 362.56
Quadro® M2000 Windows® 10 369.09
Quadro® K1200 Windows® 7 362.56
Quadro® K620 Windows® 10 362.56
Quadro® K620 Debian® 8 361.42
Quadro® 600 Debian® 8 361.45.11
Quadro® 600 Windows Vista® 348.40
Quadro® 410 Windows® 7 362.13
Quadro® FX 1800 Debian® 7 340.93
NVS 510 Ubuntu® 14.04 LTS 361.45.11
NVS 310 Ubuntu® 14.04 LTS 352.79
GeForce® GTX 950M Windows® 10 368.22

上表中所列的显卡均已通过与 COMSOL Multiphysics® 的严格兼容性测试。请注意,其他 AMD® 或 NVIDIA® 显卡同样也可能与 COMSOL Multiphysics® 兼容。与上表中所列显卡同属一种型号系列的显卡与 COMSOL Multiphysics® 兼容的可能性更高。

* 对于 Linux® 上的硬件加速,可从显卡供应商(如 NVIDIA® 或 AMD®)处获取专门的驱动程序;否则,使用 COMSOL® 软件渲染。Nouveau 视频驱动程序仅支持软件渲染。

官方支持的编译器

COMSOL Multiphysics® 在 App 开发器中提供了外部 C 接口以用于外部函数、外部材料以及外部 C 库。

Windows® macOS Linux®
外部 C 接口 Visual Studio® 2010 官方支持 Intel® Composer XE 2013.3 (也称 Intel® Compiler version 13.0.2) 及 GCC 4.2.1 官方支持 Intel® Composer XE 2013.4 (也称 Intel® Compiler version 13.1.2)及 GCC 4.2.1
Java® API JDK 1.6、1.7 或 1.8 JDK 1.6、1.7 或 1.8 JDK 1.6、1.7 或 1.8
COMSOL Multiphysics® 是使用上述 C/C++ 编译器构建和测试的。请注意,这些 C/C++ 编译器的最新版本还可能与 C 语言外部函数相兼容。当通过 <安装目录>/bin/comsolclientpath.txt 中列出的 jar 文件,在客户端/服务器模式下使用与 Java® API 共同使用的 COMSOL API 时,支持 JRE 1.6、JRE 1.7 和 JRE 1.8。当通过 <安装目录>/bin/comsolclientpath.txt 中列出的 jar 文件,在独立模式下使用与 Java® API 共同使用的 COMSOL API 时,支持 JRE 1.8。

并行系统要求 *

Windows® Mac OS X Linux®
共享内存并行 所有支持的 Windows® 版本 所有支持的 Mac OS X 版本 所有支持的 Linux® 分发版
分布内存并行
  • Windows Server® 2012 R2
  • Windows Server® 2012
  • Windows HPC Server 2008 R2
  • Windows HPC Server 2008
不支持
  • Red Hat® Enterprise Linux® 5、6 和 7
  • Debian® 7 和 8
  • Ubuntu® 12.04 和 Ubuntu® 14.041

集群中的所有计算机都必须使用同一个 Linux® 版本,且硬件应类似。建议安装 OpenFabrics Enterprise Distribution (OFED) 1.5.4.1 或更高版本。如果正在使用适用 RDMA 的网络架构 fabrics,则需要一个 DAPL 1.2 或更新版本兼容的驱动或库。软件一般与硬件同时提供。

1 有关使用 Ubuntu 14.04 LTS 及 16.04 LTS 上的共享内存的分布式并行度,请参阅环境变量 I_MPI_SHM_LMTshm

* COMSOL 很自豪是 Intel® Cluster Ready 计划的成员,每个新版本均经过了认证。查看认证信息。这一认证也保证了 COMSOL Multiphysics 可以在任何已经通过 Intel® Cluster Ready 认证的硬件上进行无缝的并行计算和集群建模。

Intel Cluster Ready

Intel、Intel Cluster Ready 和 Intel Cluster Ready 文本均为 Intel Corporation 在美国和/或其他国家或地区的商标。访问此页面进一步了解如何在云计算模式下运行 COMSOL Multiphysics 和 COMSOL Server。

FlexNet® 许可证管理器

许可证管理器的系统要求与 COMSOL Multiphysics 的要求相同。FlexNet® 版本 11.13.1.4 用于 Windows®,版本 11.13.1.3 用于 Linux® 和 Mac OS X。lmgrd 的版本必须与 COMSOL 使用的 FlexNet® 版本相同或更高。

Linux® 中的 FlexNet® 许可证管理器

Linux 系统的许可证服务器计算机需要 Linux 标准库 (LSB™)。

如果发行版的软件仓库中丢失 LSB™ 核心包,可以通过 root 用户手动创建一个符号链接:

/lib64/ld-lsb-x86-64.so.3 -> ld-linux-x86-64.so.2

分发版 所需安装包
Debian® lsb-core
Ubuntu® lsb-core
Red Hat® redhat-lsb
SUSE lsb

注意:本建议信息只是出于用户利益的考虑而提供,不应替代您根据具体情况和自身对于 COMSOL® 软件或其他软件的使用而对适用系统要求进行的考察和判断。系统和硬件会经常升级,这可能会影响您对适用系统要求的判断。