在 Linux 上安装 COMSOL

解决方法编号: 1086
标题: 在 Linux 上安装 COMSOL
平台: Linux
版本: 所有版本
类别: 安装
关键字:

问题描述

此解决方法针对 Linux 平台的安装提供一些提示和故障排除指南。有关基本安装信息,请参见 COMSOL Multiphysics 安装指南

解决方法

确认有一个显示器可用

安装程序是 X-Window 应用程序,需要访问 X-Window 显示器才能运行。请确保正确设置 DISPLAY 变量,并且您拥有对 X-Window 显示器的访问权限:从终端窗口发出命令 xclock,测试 X-Window 显示器是否正常工作(另请参见下面的故障排除 一节)。

管理权限

要将 COMSOL 软件产品安装在系统目录(如 /usr/local)中,您可能需要以 root 用户身份运行安装程序。针对 Linux 的 COMSOL 安装程序不会修改系统上除 COMSOL 安装目录以外的任何文件。

挂载 DVD

您需要在 Linux 中挂载 DVD 驱动器(如果您正在阅读本条目,则操作系统可能没有自动挂载 DVD)。具体来说,DVD 驱动器需要挂载到文件系统的装入点上。装入点与目录类似,后者可位于任何位置。不过,通常的做法是将其放入 /media 或 /mnt 目录。这两个位置是系统目录区域,因此需要 root 权限才能执行更改、添加或编辑操作。 系统中通常已存在装入点/目录,只是其中是空的。如果不存在装入点,则可以创建一个: mkdir -p /media/COMSOL54

注:您可能需要在该命令前添加 sudo,才能以 root 用户身份运行此命令。运行时需要 root 密码。 此时,用户必须确定其系统内物理 DVD 驱动器的名称。几乎所有外围设备(硬盘驱动器、DVD 驱动器、输入设备等)都安装在 /dev 目录中并命名。要找到 DVD 驱动器的名称,列出该目录:

ls /dev

将得到类似以下内容的输出(不完全相同):

bus
stderr
stdin
dvd
console ram0
ram1
(等等)

显示的内容无关紧要(因为所有系统上的输出都不同),您只需查找 dvd 或 cdrom,或类似的名称。本例中,该设备很可能简单地称为 dvd。

如果您没有 DVD 驱动器的执行权限,则安装时会出现一条常见的错误消息

安装:第 496 行: /media/COMSOL54/bin/glnxa64/setuplauncher:
权限被拒绝

您应使用以下命令重新挂载驱动器(需要以 root 身份完成,或在命令前添加 sudo):

sudo mount -o exec -t iso9660 /dev/dvd /media/COMSOL54

exec 选项用于确保磁盘具有执行权限。如果成功,您会看到类似以下内容的输出:

挂载:块设备 /dev/dvd 处于写保护状态,以只读方式挂载

否则,系统会提示 /dev/dvd 错误或 /media/COMSOL54 不存在。 如果是这种情况,请检查设备的名称并确认装入点是否存在。 现在,您可以使用驱动器的挂载目录,按上述内容运行安装程序。

故障排除

每个系统上报告的错误的具体详细信息都不相同,因此,您只需结合自己的实际情况,看看能否从以下内容中找到相似之处。

  1. 如果终端报告以下消息: 找不到安装程序(或类似消息) 或者弹出另一个意外窗口,则很可能您发出的命令是 setup,而不是 ./setup。后者会强制机器使用用户所在目录中的安装程序,而前者触发 Linux 在其路径中搜索安装程序。如果 Linux 在查找当前目录之前,先在系统上的其他位置找到安装程序,则将运行该安装程序,而这通常不是首选安装程序。

  2. 如果您尝试使用启动命令 comsol 来启动 COMSOL,并且只有一两分钟的延迟,然后返回提示符而没有显示错误消息,则很可能是您没有对 X-window 显示器的访问权限。请参见本页顶部内容。无法访问 X 显示器的另一个症状可能是出现下面的错误消息。再次通过测试 xclock 命令确保您拥有显示器的访问权限。

    GLib-GObject-警告 **:无效 (NULL) 指针实例
    GLib-GObject-CRITICAL **: g_signal_connect_data:断言 'G_TYPE_CHECK_INSTANCE(实例)' 失败
    Gtk-CRITICAL **:gtk_settings_get_for_screen:断言 'GDK_IS_SCREEN(屏幕)'失败

  3. 如果您遇到其他与图形相关的问题或因此产生崩溃,请转到解决方法 933 中的“故障排除”一节

  4. 如果 COMSOL 在访问帮助系统时崩溃,请安装以下软件包:

    Debian® 和 Ubuntu®:libwebkitgtk-1.0-0
    Red Hat® Enterprise Linux®:webkitgtk(未包含在 RHEL7 中,但可通过 EPEL 安装)。 openSUSE®:libwebkitgtk-1.0-0libwebkit-1_0-2


免责声明

COMSOL 尽一切合理的努力验证您在此页面上查看的信息。本页面提供的资源和文档仅供参考,COMSOL 对其有效性不作任何明示或暗示的声明。COMSOL 对所披露数据的准确性不承担任何法律责任。本文档中引用的任何商标均为其各自所有者的财产。有关完整的商标详细信息,请参阅产品手册。