系统要求:COMSOL Multiphysics® 6.1 版本

硬件要求

COMSOL Multiphysics® 的硬件要求包括:

  • 用于安装的工作网卡和网络连接
  • 至少 4 GB 的内存
  • 2-13 GB 的磁盘空间,具体取决于许可的产品和安装选项
  • 以下处理器:
    • 基于英特尔® 64 或 AMD64 架构的英特尔® 或 AMD® 64 位处理器(具有 SSE4 指令集)
      (2009 年以后发布的英特尔® 处理器和 2012 年以后发布的 AMD® 处理器满足这一要求。)
    • macOS 支持的 Apple Silicon 处理器(M1 及更高版本)
    • Linux® 支持的 ARMv8 处理器

此外,还需要 Adobe Acrobat® Reader 查看和打印 PDF 格式的 COMSOL 文档。

如需更多硬件配置建议,请参见相关知识库条目

操作系统要求

除以下列出的操作系统要求外,您还可以访问接口产品套件要求页面,查看“CAD 导入模块”、“设计模块”和 LiveLink™ 产品的具体要求。COMSOL Compiler™ 的系统要求与 COMSOL Multiphysics® 的系统要求相同。

64 位操作系统

架构 Windows® macOS Linux®
英特尔® 64 AMD64
  • Windows® 11
  • Windows® 11 Pro for Workstations
  • Windows® 10
  • Windows® 10 Pro for Workstations
  • Windows® 8.1
  • Windows® 7 SP11
  • Windows Server® 2022
  • Windows Server® 2019
  • Windows Server® 2016
  • Windows Server® 2012 R2
  • macOS 10.14 和 10.15 2
  • macOS 11 2
  • macOS 12 2
  • macOS 13 2
  • Debian® 10 和 11
  • Red Hat® Enterprise Linux® 7.9、8.6 和 9.0
  • CentOS® 7.9
  • Rocky Linux 8.6 和 9.0
  • Oracle® Linux® 8.6 和 9.0
  • Ubuntu® 18.04、20.04、22.04
  • SUSE® Linux Enterprise Desktop® 15 SP4
  • OpenSUSE® Leap 15.3 和 15.4
ARMv8(包括 M1 等 Apple Silicon 处理器) 不支持
  • macOS 11
  • macOS 12
  • macOS 13
  • Debian® 11
  • Red Hat® Enterprise Linux® 7.9、8.6 和 9.0
  • CentOS® 7.9
  • Rocky Linux 8.6 和 9.0
  • Oracle® Linux® 8.6 和 9.0
  • Ubuntu® 20.04 和 22.04
1 系统上必须安装 .Net 4.6.1。
2 不再支持在采用 Rosetta 2 的 Apple Silicon 上运行英特尔® 64 和 AMD64 版本。

特定操作系统的系统要求

Linux®
  • GNU C 库 2.17 或更高版本
  • Linux® 内核 3.10 或更高版本
  • FlexNet® 许可证管理器需要 Linux Standard Base (LSB™)1

1 请查看以下有关 Linux® 上的 FlexNet® 许可证管理器的信息。

Linux® 上的帮助系统

为了在 Linux® 操作系统上运行帮助系统,需要安装 WebKitGTK 包。支持 2.32 以下的版本。一些更高的版本存在稳定性问题,可能会也可能不会影响 COMSOL®。WebKitGTK 包在不同的 Linux® 发行版中以不同的名称提供:

Linux® 发行版 软件包名称
Debian® 10 和 11 libwebkit2gtk-4.0-37
Ubuntu® 18.04、20.04 和 22.04 libwebkit2gtk-4.0-37
Red Hat® Enterprise Linux® 7 和 CentOS® 7 webkitgtk4
Red Hat® Enterprise Linux® 8、Rocky Linux 8 和 Oracle® Linux 8 webkit2gtk3
Red Hat® Enterprise Linux® 9、Rocky Linux 9 和 Oracle® Linux 9 webkit2gtk3
SUSE® Linux Enterprise Desktop® 15 libwebkit2gtk-4_0-37
OpenSUSE® Leap 15.3 和 15.4 libwebkit2gtk-4_0-37

FlexNet® 许可证管理器

许可证管理器的系统要求与 COMSOL Multiphysics® 的系统要求相同。COMSOL® 6.1 通常与早期 COMSOL® 版本的 FlexNet®“许可证管理器”版本不兼容。因此,在升级到 COMSOL® 6.1 时,您还需要升级许可证管理器。FlexNet® 11.18.3 版本支持在所有平台的 COMSOL® 6.1 中使用。lmgrd 的版本不得低于 COMSOL® 软件使用的 FlexNet® 版本。

Linux® 上的 FlexNet® 许可证管理器

Linux® 系统的许可证服务器计算机需要 Linux Standard Base (LSB™)。

如果分发存储库中缺少 LSB™ 核心软件包,请以 root 身份手动创建一个符号链接:

  • 对于英特尔® 64 和 AMD64 架构:
    ln -s /lib64/ld-linux-x86-64.so.2 /lib64/ld-lsb-x86-64.so.3
  • 对于 ARMv8:
    ln -s /lib64/ld-linux-aarch64.so.1 /lib64/ld-lsb-aarch64.so.3
发行版 所需软件包
Debian® lsb-core
Ubuntu® lsb-core
Red Hat® redhat-lsb
SUSE® lsb

App 开发器

Windows® 操作系统支持“App 开发器”。

模型管理器

除“课堂许可证套装”以外,其他所有许可证都支持使用本地“模型管理器”数据库。使用本地“模型管理器”数据库时,它需要位于您的计算机上,而不能放在网络或云驱动器上。您可以使用“网络浮动许可证”进行安装并连接到中央“模型管理器服务器”。

用于 Microsoft® PowerPoint® 和 Microsoft® Word 的插件

在 Windows® 操作系统上,用于 PowerPoint® 和 Word 的 COMSOL 插件与以下版本兼容:2010、2013、2016、2019 和 2021。不支持 PowerPoint® 和 Word 2010 Starter。如果您使用的是 Microsoft 365,则必须在计算机上安装 PowerPoint® 和 Word - 这些插件需要支持 VSTO 插件的 PowerPoint® 和 Word 版本。

并行系统要求

Windows® macOS Linux®
共享内存并行 所有支持的 Windows® 版本 所有支持的 macOS 版本 所有支持的 Linux® 发行版
分布式内存并行
  • Windows Server® 20221
  • Windows Server® 20191
  • Windows Server® 20161
  • Windows Server® 2012 R21
不支持
  • Red Hat® Enterprise Linux® 7 和 82
  • CentOS® 72
  • Debian® 102
  • Ubuntu® 18.04 和 20.042

1 需要相应 Windows Server 版本的 Microsoft® HPC Pack。

2 集群中的所有计算机都必须使用相同的 Linux® 版本,并应采用相似的硬件。建议您安装 Open Fabric Interface (OFI) 1.5.0 或更高版本。如果使用的是支持 RDMA 的网络架构,则需要与 DAPL 1.2 或更高版本兼容的驱动程序或库,所需软件通常随硬件一起提供。使用 MPICH2 时,应在所有集群节点上安装 libatomic 包。

有关如何在云中运行 COMSOL Multiphysics® 和 COMSOL Server™ 的信息,请查看此页面

官方支持的编译器

COMSOL Multiphysics® 在“App 开发器”中提供外部 C 接口,用于访问外部函数、外部材料以及外部 C 库。

Windows® macOS(英特尔) macOS (Apple Silicon) Linux®(英特尔® 64 和 AMD64) Linux® (ARMv8)
外部 C 接口 Microsoft Visual Studio® 2017 官方支持英特尔® Parallel Studio XE Composer Edition for C++ macOS 20.4(也称为英特尔® C++ 编译器 19.1.3.301 版本)和 Apple LLVM 11.0.3 版本 (clang-1103.0.32.62) Apple clang 13.0.0 版本 (LLVM 12) 官方支持英特尔® Parallel Studio XE Composer Edition for C++ Linux® 20.4(也称为英特尔® C++ 编译器 19.1.3.304 版本)和 GCC 9.4.0 GCC 12.2.0
Java® API JDK 8 和 11 JDK 8 和 11 JDK 8 和 11 JDK 8 和 11 JDK 8 和 11

COMSOL Multiphysics® 使用上述 C/C++ 编译器进行构建和测试。请注意,这些 C/C++ 编译器的更高版本也可能与外部 C 接口兼容。将 COMSOL API(在客户端/服务器模式下用于 Java® API)与 <installation dir>/bin/comsolclientpath.txt 中列出的 jar 文件一起使用时,支持 JRE 8 和 11。将 COMSOL API(在独立模式下用于 Java® API)与 <installation dir>/bin/comsolpath.txt 中列出的 jar 文件一起使用时,支持 JRE 11。

Java 环境

COMSOL 附带有 OpenJDK 11.0.13。您可以在安装过程中选择备选的 Java® 11 版本 11.0.9.1 或更高版本。

图形系统要求

基于性能方面的考虑,COMSOL 建议使用硬件渲染,这需要驱动程序支持 OpenGL® 2.1 或更高版本。Windows® 操作系统用户也可以使用 DirectX® 9 版本。

要在“图形”首选项中设置优化质量 时使用所有可用的渲染特征,建议使用不小于 2 GB 的图形内存。

AMD®

Windows® 11

显卡型号 驱动程序版本
AMD Radeon™ Pro W6400 22.Q3
AMD Radeon™ Pro W5700 22.Q3
AMD Radeon™ Pro W5500 22.Q3
AMD Radeon™ Pro WX 9100 22.Q3
AMD Radeon™ Pro WX 8200 22.Q3

Windows® 10

显卡型号 驱动程序版本
AMD Radeon™ Pro W6800 22.Q3
AMD Radeon™ Pro W6600 22.Q3
AMD Radeon™ Pro VII 22.Q3

Ubuntu® 22.04

显卡型号 驱动程序版本
AMD Radeon™ Pro W6800 AMDGPU (Linux® 5.15.0)
AMD Radeon™ Pro W6600 AMDGPU (Linux® 5.15.0)
AMD Radeon™ Pro W6400 AMDGPU (Linux® 5.15.0)
AMD Radeon™ Pro W5700 AMDGPU (Linux® 5.15.0)
AMD Radeon™ Pro W5500 AMDGPU (Linux® 5.15.0)
AMD Radeon™ Pro VII AMDGPU (Linux® 5.15.0)
AMD Radeon™ Pro WX 9100 AMDGPU (Linux® 5.15.0)
AMD Radeon™ Pro WX 8200 AMDGPU (Linux® 5.15.0)

NVIDIA®

Windows® 11

显卡型号 驱动程序版本
Quadro® RTX A5500 517.40
Quadro® RTX A5000 517.40
Quadro® RTX A4000 517.40
Quadro® RTX A3000 517.40
Quadro® RTX A1000 517.40
Quadro® RTX 6000 517.40
Quadro® RTX 4000 517.40

Windows® 10

显卡型号 驱动程序版本
Quadro® RTX A2000 517.40
Quadro® RTX 3000 517.40
Quadro® T1000 517.40
Quadro® T400 517.40
Quadro® T600-R 517.40

以上列出的显卡已经过严格测试,均与 COMSOL Multiphysics® 软件兼容。但请注意,其他 AMD® 或 NVIDIA® 显卡也可能与 COMSOL Multiphysics® 兼容。与上面所列任一显卡属于相同型号系列的显卡更可能与 COMSOL Multiphysics® 兼容。

对于 Linux® 上的硬件加速,请使用显卡供应商的专有驱动程序,如 NVIDIA®;否则请使用 COMSOL® 软件渲染。Nouveau 视频驱动程序仅支持软件渲染。

注:本建议信息只是出于用户利益的考虑而提供,不应代替您根据具体情况和自身对于 COMSOL® 软件或其他软件的使用而对适用系统要求进行的考察和判断。系统和硬件的定期更新可能会影响您对适用系统要求的判断。

Adobe 和 Acrobat 是 Adobe Systems Incorporated 在美国和/或其他国家/地区的注册商标或商标。AMD、AMD 速龙、FirePro 和 Radeon 是 Advanced Micro Devices, Inc. 的商标或注册商标。Debian 是 Software in the Public Interest, Inc. 在美国的注册商标。FlexNet 是 Flexera Software LLC. 的注册商标。NVIDIA 和 NVIDIA Quadro 是 NVIDIA Corporation 在美国和/或其他国家/地区的注册商标。英特尔和奔腾是英特尔公司或其子公司在美国和/或其他国家/地区的商标。Oracle 和 Java 是 Oracle 和/或其关联公司的注册商标。Red Hat、Red Hat Enterprise Linux 和 CentOS 是 Red Hat, Inc. 的注册商标。Ubuntu 是 Canonical Ltd. 的注册商标。OpenGL 是 Silicon Graphics, Inc. 在美国和/或其他国家/地区的商标或注册商标。OpenSUSE 和 SUSE 是 SUSE LLC. 的注册商标。Linux、Linux Standard Base 和 LSB 是 Linus Torvalds 在美国和其他国家/地区的商标或注册商标。Apple 和 macOS 是 Apple Inc. 在美国和其他国家/地区的商标。Microsoft、DirectX、PowerPoint、Visual Studio、Windows 和 Windows Server 是 Microsoft Corporation 在美国和/或其他国家/地区的注册商标或商标。COMSOL AB 及其子公司和产品不与上述商标所有者相关联,亦不由其担保、赞助或支持。