系统要求:COMSOL Multiphysics® 5.4 版本

以下要求适用于所有平台:

  • 安装过程中建议使用正常工作的网卡并连接 Internet
  • 建议至少 4 GB RAM
  • 2-10 GB 的磁盘空间,具体取决于许可的产品和安装选项
  • Adobe® Acrobat® Reader,用于查看和打印 PDF 格式的 COMSOL 文档
  • 基于英特尔® 64 或 AMD64 架构的英特尔® 或 AMD® 64 位处理器

如需更多硬件配置建议,请参见相关技术支持知识库条目

操作系统要求

除下面列出的操作系统要求外,您还可以访问接口产品套件要求页面,查看“CAD 导入模块”、“设计模块”和 LiveLink™ 产品的特定要求。COMSOL Compiler™ 和编译 App 的系统要求与 COMSOL Multiphysics® 的系统要求相同。

Windows® macOS Linux®
64 位操作系统
  • Windows® 10
  • Windows® 10 Pro for Workstations
  • Windows® 8.1
  • Windows® 7 SP1
  • Windows Server® 2016
  • Windows Server® 2012 R2
  • Windows Server® 2012
  • Windows Server® 2008 R2 SP1
  • Windows HPC Server 2008 R2 SP1
macOS 10.10、10.11、10.12、10.13 和 10.14
  • Debian® 8 和 9
  • Red Hat® Enterprise Linux® 6.10 和 7.5
  • CentOS 7.5
  • Ubuntu® LTS 14.04、16.04 和 18.04
  • OpenSUSE® Leap 15 和 42.3

特定操作系统的系统要求

Linux®
  • GNU C 库 2.11.3 或更高版本
  • Linux® 内核 2.6.32 或更高版本
  • 英特尔® 奔腾® IV 或 AMD 速龙™ XP 处理器或更高版本
  • FlexNet® 需要 Linux Standard Base (LSB™)1

1请参见以下有关 Linux® 上的 FlexNet® 许可证管理器的信息。

Linux® 上的帮助系统

为了在 Linux® 操作系统上运行帮助系统,需要安装以下软件包:

  • Debian® 和 Ubuntu®libwebkitgtk-1.0-0
  • RHEL 6 和 CentOS 6:webkitgtk
  • RHEL 7 和 CentOS 7:webkitgtk4
  • openSUSE Leap 15:libwebkit2gtk-4_0-37
  • openSUSE Leap 42.3:libwebkitgtk-1_0-0

如果未安装 libwebkitgtk,帮助系统仍可以正常运行,但将在单独的窗口中打开。对于 RHEL 7 和 CentOS 7,COMSOL Multiphysics® 将始终打开单独的窗口来显示帮助系统和“案例库更新”。

FlexNet® 许可证管理器

许可证管理器的系统要求与 COMSOL Multiphysics® 的系统要求相同。FlexNet® 11.15.1 版本支持在所有平台上使用。lmgrd 的版本不得低于 COMSOL® 软件使用的 FlexNet® 版本。

Linux® 上的 FlexNet® 许可证管理器

Linux® 系统的许可证服务器计算机需要 Linux Standard Base (LSB™)。

如果分发存储库中缺少 LSB™ 核心软件包,请以 root 身份手动创建一个符号链接:

ln -s /lib64/ld-linux-x86-64.so.2 /lib64/ld-lsb-x86-64.so.3

发行版 所需软件包
Debian® lsb-core
Ubuntu® lsb-core
Red Hat® redhat-lsb
SUSE® lsb

App 开发器

“App 开发器”支持 Windows® 操作系统。

并行系统要求

Windows® macOS Linux®
共享内存并行 所有支持的 Windows® 版本 所有支持的 macOS 版本 所有支持的 Linux® 发行版
分布式内存并行
  • Windows Server® 2016
  • Windows Server® 2012 R2
  • Windows Server® 2012
  • Windows HPC Server 2008 R2 SP1
不支持
  • Red Hat® Enterprise Linux® 6.10 和 7.5
  • CentOS 7.5
  • Debian® 8 和 9
  • Ubuntu® LTS 16.04 和 18.04

集群中的所有计算机都必须使用相同的 Linux® 版本,并采用相似的硬件。建议您安装 OpenFabrics Enterprise Distribution (OFED) 1.5.4.1 或更高版本。如果使用的是支持 RDMA 的网络架构,则需要与 DAPL 1.2 或更高版本兼容的驱动程序或库,该软件通常随硬件一起提供。

有关如何在云中运行 COMSOL Multiphysics® 和 COMSOL Server™ 的信息,请查看此页面

官方支持的编译器

COMSOL Multiphysics® 在“App 开发器”中提供外部 C 接口,用于访问外部函数、外部材料以及外部 C 库。

Windows® macOS Linux®
外部 C 接口 Microsoft Visual Studio® 2017 官方支持英特尔® Composer XE 2015.7(也称为英特尔® 编译器 15.0.7 版本)和 Apple LLVM 6.0 版本 (clang-600.0.57) 官方支持英特尔® Composer XE 2015.7(也称为英特尔® 编译器 15.0.7 版本)和 GCC 4.9.2
Java® API JDK 1.6、1.7 或 1.8 JDK 1.6、1.7 或 1.8 JDK 1.6、1.7 或 1.8

COMSOL Multiphysics® 使用上述 C/C++ 编译器进行构建和测试。请注意,这些 C/C++ 编译器的更高版本也可能与外部 C 接口兼容。通过 <安装目录>/bin/comsolclientpath.txt 中列出的 jar 文件在客户端/服务器模式下使用适用于 Java® API 的 COMSOL API 时,支持 JRE 1.6、JRE 1.7 和 JRE 1.8。通过 <安装目录>/bin/comsolpath.txt 中列出的 jar 文件在独立模式下使用适用于 Java® API 的 COMSOL API 时,支持 JRE 1.8。

图形系统要求

基于性能方面的考虑,COMSOL 建议使用硬件渲染,这需要驱动程序支持 OpenGL® 2.0 版本。Windows® 操作系统用户也可以在本地控制台上使用 DirectX® 9 版本。硬件渲染至少需要 24 位彩色图形。

“图形”首选项中的优化质量 设置需要 OpenGL® 2.0。软件渲染还支持 16 位彩色图形。为提高性能,我们建议显卡内存不小于 512 MB。

AMD®

显卡型号 操作系统 驱动程序版本
AMD Radeon™ Pro WX 9100 Windows® 10 18.Q3
AMD Radeon™ Pro WX 8200 Windows® 10 18.Q3
AMD Radeon™ Pro WX 7100 Windows® 10 18.Q3
AMD Radeon™ Pro WX 5100 Windows® 10 18.Q3
AMD Radeon™ Pro WX 4100 Windows® 7 和 10 18.Q3
AMD Radeon™ Pro WX 3100 Windows® 10 18.Q3
AMD Radeon™ Pro WX 2100 Windows® 10 18.Q3
AMD Radeon™ Pro WX 2100 Fedora 28 AMDGPU (Linux 4.18)
AMD FirePro™ W7100 Windows® 10 18.Q3
AMD FirePro™ W5100 Windows® 8.1 17.Q3.1
AMD FirePro™ W4100 Windows® 10 18.Q3

NVIDIA®

显卡型号 操作系统 驱动程序版本
Quadro® P4000 Windows® 10 392.00
Quadro® P3200 Windows® 10 392.00
Quadro® P2000 Windows® 10 392.00
Quadro® P1000 Windows® 10 392.00
Quadro® P600 Windows® 7 和 10 392.00
Quadro® M2000 Windows® 10 392.00
Quadro® K2200 Windows® 7 392.00
Quadro® K1200 Windows® 10 392.00
Quadro® K620 Windows® 8.1 392.00
Quadro® K5000 Windows® 7 377.83
Quadro® K4000 Windows® 7 377.83
Quadro® K2000 Windows® 7 377.83
Quadro® K600 Ubuntu® 16.04 390.67

以上列出的显卡已经过严格测试,均与 COMSOL Multiphysics® 软件兼容。但请注意,其他 AMD® 或 NVIDIA® 显卡也可能与 COMSOL Multiphysics® 兼容。与上面所列任一显卡属于相同型号系列的显卡更可能与 COMSOL Multiphysics® 兼容。

对于 Linux® 上的硬件加速,请使用显卡供应商的专有驱动程序,如 NVIDIA®;否则请使用 COMSOL® 软件渲染。Nouveau 视频驱动程序仅支持软件渲染。

注:本建议信息只是出于用户利益的考虑而提供,不应代替您根据具体情况和自身对于 COMSOL® 软件或其他软件的使用而对适用系统要求进行的考察和判断。系统和硬件会定期更新,这可能会影响您对适用系统要求的判断。

Adobe 和 Acrobat 是 Adobe Systems Incorporated 在美国和/或其他国家/地区的注册商标或商标。AMD、AMD 速龙、FirePro 和 Radeon 是 Advanced Micro Devices, Inc. 的商标或注册商标。Debian 是 Software in the Public Interest, Inc. 在美国的注册商标。FlexNet 是 Flexera Software LLC. 的注册商标。NVIDIA 和 NVIDIA Quadro 是 NVIDIA Corporation 在美国和/或其他国家/地区的注册商标。英特尔和奔腾是英特尔公司或其子公司在美国和/或其他国家/地区的商标。Oracle 和 Java 是 Oracle 和/或其关联公司的注册商标。Red Hat 和 Red Hat Enterprise Linux 是 Red Hat, Inc. 的注册商标。Ubuntu 是 Canonical Ltd. 的注册商标。OpenGL 是 Silicon Graphics, Inc. 在美国和/或其他国家/地区的商标或注册商标。OpenSUSE 和 SUSE 是 SUSE LLC. 的注册商标。Linux、Linux Standard Base 和 LSB 是 Linus Torvalds 在美国和其他国家/地区的商标或注册商标。macOS 是 Apple Inc. 在美国和其他国家/地区的商标。Microsoft、DirectX、Visual Studio、Windows 和 Windows Server 是 Microsoft Corporation 在美国和/或其他国家/地区的注册商标或商标。COMSOL AB 及其子公司和产品不与上述商标所有者相关联,亦不由其担保、赞助或支持。